Задать вопрос

Написать программу которая определяет количество положительных элементов одномерного массива

+3
Ответы (1)
  1. 28 октября, 01:41
    0
    var

    i, n: longint;

    a: array [1 ... 10] of longint;

    begin

    n : = 0;

    randomize;

    for i : = 1 to 10 do

    begin

    a[i] : = random (100) - 50;

    write (a[i], ' ');

    if a[i] > 0 then

    n : = n + 1;

    end;

    writeln;

    write ('Количество положительных членов данного одномерного массива равно ');

    writeln (n, '.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу которая определяет количество положительных элементов одномерного массива ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Вычислите сумму элементов одномерного массива А (10). 2) Вычислите произведение элементов одномерного массива А (10). 3) Вычислите сумму четных чисел в массиве А (10). 4) Задан массив из N элементов. Определить максимальный (минимальный) элемент.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Составьте программу которая подсчитывает количество положительных элементов одномерного массива
Ответы (1)