Задать вопрос

На языке Паскаля. Составе программу, которая вводится с клавиатуры последовательность из пяти висели после ввода каждого числа выводят среднее арифметическое полученной части последовательности.

+3
Ответы (1)
  1. 8 февраля, 17:13
    0
    program aver;

    var n, s: integer; / /n - число, s - сумма чисел

    a: real; / /Среднее значение введенных чисел

    begin

    s: = 0;

    for i:integer:=1 to 5 do

    begin

    write ('Введите число: ');

    readln (n);

    s: = s + n;

    a: = s / i;

    writeln ('Среднее значение введенных чисел: ', a)

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «На языке Паскаля. Составе программу, которая вводится с клавиатуры последовательность из пяти висели после ввода каждого числа выводят ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Собери из суждений правильное умозаключение. №1 все устройства ввода служат для ввода информации. №2 клавиатура служит для ввода информации. №3 клавиатура устройство ввода
Ответы (1)
Найти среднее арифметическое элементов последовательности, превосходящих некоторое число C. Массив задан с клавиатуры. Размер произвольный. Значение C вводится с клавиатуры.
Ответы (1)