Задать вопрос

С клавиатуры вводетьмя массиа из n целых чисел, составить программу и вывести на экран все элементы массива. которые стгят на не четных номерах и найти их сумму.

+4
Ответы (1)
  1. 19 октября, 18:24
    0
    Program Solution;

    Const

    N = 10;

    Var

    A:Array[0 ... N] Of Integer;

    i, k:Integer;

    Begin

    k:=0;

    Randomize;

    {Заполняем случайно массив}

    For i:=0 To N Do

    Begin

    A[i]:=Random (89) + 10; {числа в 10 ... 99}

    Write (A[i],' ');

    End;

    WriteLn;

    WriteLn ('New Array');

    {Выводит сначала четные числа}

    For i:=0 To N Do

    If A[i] Mod 2 = 0 Then

    Write (A[i],' ');

    {Потом нечетные}

    For i:=0 To N Do

    If A[i] Mod 2 = 1 Then

    Write (A[i],' ');

    ReadLn;

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводетьмя массиа из n целых чисел, составить программу и вывести на экран все элементы массива. которые стгят на не четных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)