Задать вопрос
1 января, 14:17

Вычислите при помощи языка Питон факториал числа 50 - произведение всех натуральных чисел от 1 до 50 (1∗2∗3∗ ...∗501∗2∗3∗ ...∗50).

+2
Ответы (1)
  1. 1 января, 15:44
    0
    program time;

    var n, factorial, i: integer;

    begin

    factorial : = 1;

    readln (n);

    for i : = 1 to n do

    begin

    factorial : = factorial * i;

    end;

    writeln (factorial);

    end.

    Второй вариант выполнения программы

    def factorial (n):

    if n = 0:

    return 1

    else:

    return n * factorial (n-1)

    print (factorial (50))
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислите при помощи языка Питон факториал числа 50 - произведение всех натуральных чисел от 1 до 50 (1∗2∗3∗ ...∗501∗2∗3∗ ...∗50). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан двумерный массив размером n*n. Создать функцию которая находит факториал каждого элемента массива и заменяет исходный элемент на его факториал (значение функции). в первой строке написано число n.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Факториалом называется произведение последовательных целых чисел, например 3! (читается "3 факториал") = 1-2-3 = 6. Вычисления выполняются в 16-разрядной целочисленной арифметике со знаком.
Ответы (1)
1. Найти произведение всех натуральных чисел, кратных 3 и меньших 13. Обратите внимание, что начальное значение Р=1. 2. Найти количество натуральных чисел, нечет
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)