Задать вопрос
16 января, 00:59

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует такой треугольник, то определите его тип (равносторонний, равнобедренный, разносторонний) Пример входных данный Пример выходных данных a b c>> 1 2 1 Не существует a b c>> 2 2 2 Равносторонний a b c>> 20 20 30 Равнобедренный a b c>> 3 4 5 Разносторонний

+4
Ответы (1)
  1. 16 января, 03:49
    0
    program zz1;

    var a, b, c:integer; / /задаем переменные целого типа

    begin

    write ('введите первую сторону треугольника ');

    read (a);

    write ('введите вторую сторону треугольника ');

    read (b);

    write ('введите третью сторону треугольника ');

    read (c);

    If (a + b > c) and (c + b > a) and (a + c > b) Then

    begin

    write (' существует ');

    If (a = b) and (c = b) and (a = c) Then write (' равносторонний ')

    else

    If (a b) and (c b) and (a c) Then write (' разносторонний ')

    else

    If (a = b) or (c = b) or (a = c) Then write (' равнобедренный ');

    end

    else write (' не существует ');

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует такой ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его типИмеются данные о количестве полных лет трех призеров спартакиады.
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
известны длины сторон треугольника a, b, c. напишите на языке Паскаль программу, вычисляющую площадь этого треугольника. пример входных данных: а=3 b=4c=5. пример выходных данных S=6.0
Ответы (1)
Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника. Пример входных данных: xa=2 ya=1 xb=6 yb=5 xc=10 yc=1 Пример выходных данных: S=16.0
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)