Задать вопрос

Написать программу, которая принимает на вход двухзначное число, а выводит на экран число, у которого цифры меняются местами. Например, вводится число 37, а выводится 73. Подсказка: используйте операторы div и mod.

+4
Ответы (1)
  1. 19 мая, 15:42
    0
    Чтобы цифры поменялись местами нужно число единиц умножить на десять, а число десятков записать вместо единиц. Число единиц можно найти как остаток после деления на 10. Число десятков равно целой части частного после деления на 10.

    Пример: исходное число 43.

    43 mod 10 = 3;

    (43 mod 10) * 10 = 3 * 10 = 30;

    43 div 10 = 4;

    30 + 4 = 34.

    program change;

    var n: integer;

    begin

    Writeln ('Введите двузначное число');

    readln (n);

    writeln ('Число после обмена цифр местами:')

    writeln ((n mod 10) * 10 + n div 10);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая принимает на вход двухзначное число, а выводит на экран число, у которого цифры меняются местами. Например, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы