Задать вопрос

Ввести число. Если оно неотрицательное, вычесть из него 50, в противном случае прибавить к нему 100

+3
Ответы (1)
  1. 21 марта, 08:34
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное число '); / / вводим с клавиатуры число

    read (x);

    if x < 0 / / проверяем, если введенное число отрицательное, то

    then y:=x + 100 / / вычисляем ответ, прибавив к исходному числу сто

    else y:=x - 50; / / иначе, вычисляем ответ, отняв от исходного числа пятьдесят

    write (' Полученный ответ = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести число. Если оно неотрицательное, вычесть из него 50, в противном случае прибавить к нему 100 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести число если оно не отрицательно вычесть из него 50, в противном случае прибавить к нему 100. Решение
Ответы (1)
Запишите команду присваивания, в результате выполнения которой логическая переменная t получает значение true, если выполняется указанное условие, и значение false в противном случае. а) х - неотрицательное число.
Ответы (1)
Обозначим символом Z бит, определяющий факт равенства результата R нулю, а символом N - бит, фиксирующий отрицательность R: Z = 1 при R = 0, иZ=0 в противном случае; N = 1 при ЯR О, и 0 в противном случае.
Ответы (1)
Задуманно число Х. Если оно больше 10, то прибавить к нему 2, в противном случае умножь на 2. Составте алгоритм данной задачи.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)