Задать вопрос

1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1; i:=1; while i < 5 do begin S : = S + i * (i+1); i : = i + 1; end; 3) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 14; s : = 0; while n < = 18 do begin s : = s + 25; n : = n + 1 end;

+4
Ответы (1)
  1. 1 марта, 07:49
    0
    1)

    Ответ: значение переменной s=707

    2)

    S:=1

    i:=1

    i < 5 1 < 5 Истина

    S : = S + i * (i + 1) = 1 + 1 * (1 + 1) = 1 + 1 * 2 = 1 + 2 = 3

    i : = i + 1 = 1 + 1 = 2

    i < 5 2 < 5 Истина

    S : = S + i * (i + 1) = 3 + 2 * (2 + 1) = 3 + 2 * 3 = 3 + 6 = 9

    i : = i + 1 = 2 + 1 = 3

    i < 5 3 < 5 Истина

    S : = S + i * (i + 1) = 9 + 3 * (3 + 1) = 9 + 3 * 4 = 9 + 12 = 21

    i : = i + 1 = 1 + 1 = 4

    i < 5 4 < 5 Истина

    S : = S + i * (i + 1) = 21 + 4 * (4 + 1) = 21 + 4 * 5 = 21 + 20 = 41

    i : = i + 1 = 1 + 1 = 5

    i < 5 5 < 5 Ложь

    Ответ: значение переменной s=41

    3)

    Ответ: значение переменной s=125
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin n : = 1; s : = 0; while n < = 20 do begin s : = s + 33; n : = n + 1 end; write (s) end.
Ответы (1)