Задать вопрос

Даны 10 чисел. Найти сумму их квадратов

+2
Ответы (1)
  1. 27 октября, 13:43
    0
    program zz1;

    var i, a, S:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 10 do / / организуем цикл на 10 повторений

    begin

    read (a); / / вводим с клавиатуры очередное число

    S:=s + a * a; / / вычисляем квадрат введенного числа и добавляем его в сумму

    end;

    writeln (' Сумма квадратов десяти введенных чисел = ', S); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны 10 чисел. Найти сумму их квадратов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n - вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если n-нечетное. Использовать цикл WHILE
Ответы (1)