Задать вопрос
31 марта, 03:40

Дано целое число N (>0). Найти сумму (1+2) ^2 + (2+3) ^2 + ... + (N + (N+1)) ^2 Написать программу для Pascal

+4
Ответы (1)
  1. 31 марта, 04:33
    0
    Текст рабочей программы с комментариями.

    program sum;

    var i, n, s: integer; //целочисленные переменные для счетчика циклов, введенного

    / / числа и суммы членов ряда

    begin

    s:=0; / / переменная для накопления результата в цикле

    readln (n); / /Ввод целого числа

    for i:=1 to n do / /число циклов равно введенному числу

    s:=s+sqr (i+i+1); / / на каждом шаге к предыдущему значению s

    //добавляется значение (i + (i+1)) ^2

    writeln ('s=', s); / /вывод результата

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано целое число N (>0). Найти сумму (1+2) ^2 + (2+3) ^2 + ... + (N + (N+1)) ^2 Написать программу для Pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано целое неотрицательное число N, определите число десятков в нем (предпоследнюю цифру числа). Если предпосленей цифры нет, то можно считать, что число десятков равно нулю. (Напишите программу для решения в Pascal. ABC)
Ответы (1)
1. Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal
Ответы (1)
1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1
Ответы (1)