Задать вопрос

составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок

+3
Ответы (1)
  1. 16 июня, 01:24
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i, k1, k2:integer; / / задаем переменные целого типа

    begin

    write (' введите заданную формулу ');

    read (s); / / вводим с клавиатуры заданную формулу

    for i:=1 to length (s) do / / организуем цикл от первого до последнего символа формулы

    begin

    if s[i] = ' (' then k1:=k1 + 1; / /считаем открывающиеся скобки

    if s[i] = ') ' then k2:=k2 + 1; / /считаем закрывающиеся скобки

    end;

    writeln ('в заданной формуле открывающихся скобок = ', k1); / / выводим ответ

    write ('в заданной формуле закрывающихся скобок = ', k2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу, которая по номеру месяца, введенного с клавиатуры, выводит количество дней в нем.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200 см считает количество спортсменов рост которых больше 190 см а также средний рост всех спортсменов
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)