Задать вопрос
15 сентября, 21:36

Составить программу в Pascal. В которую введя любое трехзначное число оно выводит число-перевертыш (пример ввожу 122 и мне выводит 121 или 569 и и мне 565)

+3
Ответы (1)
  1. 15 сентября, 22:57
    0
    var

    s, s2: string;

    n, m: longint;

    i, err: integer;

    begin

    writeLn ('Введите целое трехзначное число: ');

    readln (n);

    str (n, s);

    s2 : = '';

    for i : = length (s) downto 1 do

    s2 : = s2 + s[i];

    val (s2, m, err);

    writeLn ('Полученное число: ', M, '.');

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в Pascal. В которую введя любое трехзначное число оно выводит число-перевертыш (пример ввожу 122 и мне выводит 121 или ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Написать программу на языке Pascal. Написать программу, которая выводит 10 одинаковых чисел
Ответы (1)
Pascal! Написать программу, которая выводит на экран окружность, радиус которой "растет" из центра Измените программу так, что бы окружность сначала уменьшалась в радиусе, а потом увеличивалась
Ответы (1)