Задать вопрос

Составить программу, которая вводит с клавиатуры массив из 5 элементов, и находит среднее арифметическое этих чисел.

+1
Ответы (1)
  1. 9 октября, 10:42
    0
    program zz1;

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... 5] of integer;

    begin

    for i:=1 to 5 do / / записываем в массив пять чисел с клавиатуры

    read (m[i]);

    for i:=1 to 5 do / / организуем цикл, в котором переберем все элементы массива

    k:=m[i] + k; / / добавляем к сумме элемент из массива

    writeln (' среднее арифметическое элементов массива = ', k / 5); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая вводит с клавиатуры массив из 5 элементов, и находит среднее арифметическое этих чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.
Ответы (1)