Задать вопрос

Дана строка, содрежащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие четыре буквы. паскаль

+4
Ответы (1)
  1. 12 мая, 01:57
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i, k, l:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    s:=' '+s; / / добавляем в начало строки пробел

    for i:=1 to length (s) do

    begin

    if (s[i]=' ') and (s[i+1]' ') and (s[i+1]'.') then

    l:=i+1;

    if (s[i]' ') and (s[i]'.') and ((s[i+1]='.') or (s[i+1]=' ')) then

    begin

    k:=i;

    if ((k-l) + 1=4) then writeln (copy (s, k-3,4)); / / проверяем, если расстояние между пробелами четыре буквы, то выводим слово на экран

    end;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана строка, содрежащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие четыре буквы. паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана строка, содержащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие три буквы.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Напишите программу ввода чисел а, b с клавиатуры. Если a=b, то вывести на экран сумму a и b, иначе вывести на экран b-a (используя Функцию) Паскаль
Ответы (1)
По заданному числу K (от 0 до 10) вывести его название. Например при K=2 вывести на экран , при K=3 вывести на экран и т. д
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)