Задать вопрос
27 сентября, 03:23

Дан массив A [1 ... 18, 1 ... n] и натуральное число n. Составить программу поиска наибольшего по модулю элемента массива, а также индекса этого элемента.

+1
Ответы (1)
  1. 27 сентября, 07:07
    0
    program arrays_19;

    const n=5; / / задаем n

    var i, j, x1, x2, k: integer;

    m: array[1 ... 18,1 ... n] of integer;

    begin

    for i:=1 to 18 do begin

    for j:=1 to n do begin

    m[i, j]:=random (101) - 50; / / заполнение матрицы случайными числами и вывод на экран

    write (m[i, j]:5);

    end;

    writeln;

    end;

    k:=-100000; / / задаем начальное значение для максимального

    for i:=1 to 18 do begin

    for j:=1 to n do begin

    if abs (m[i, j]) >k then begin k:=m[i, j]; x1:=i; x2:=j; end;

    end;

    end;

    write (' максимальный элемент по модулю = ', k,' его индексы ', x1,' ', x2); / / вывод ответа

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив A [1 ... 18, 1 ... n] и натуральное число n. Составить программу поиска наибольшего по модулю элемента массива, а также индекса ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)