Задать вопрос

Даны три целых числа. Найти количество положительных чисел в исходном наборе.

+4
Ответы (1)
  1. 10 января, 14:51
    0
    program zz1;

    var a, b, c, i:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if a > 0 then i:=i + 1; / / проверяем, если первое число положительное, то считаем его

    if b > 0 then i:=i + 1; / / проверяем, если второе число положительное, то считаем его

    if c > 0 then i:=i + 1; / / проверяем, если третье число положительное, то считаем его

    write (' количество положительных чисел ', i); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны три целых числа. Найти количество положительных чисел в исходном наборе. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)