Задать вопрос

Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. Для паскаля

+5
Ответы (1)
  1. 24 февраля, 16:29
    0
    Var a, a1, a2, a3:integer;

    begin

    write (a = );

    readln (a);

    a1:=a div 100;

    a2:=a div 10 mod 10;

    a3:=a mod 10;

    if (a1 mod 2 = 0) or (a2 mod 2 = 0) or (a3 mod 2 = 0)

    then writeln (В числе есть четные цифры)

    else writeln (В числе нет четных цифр);

    end.

    Пример:

    a = 519

    В числе нет четных цифр
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. Для паскаля ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обменяются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Написать программу вывода на экран чисел, если они чётные и индексы их ячеек чётные.
Ответы (1)