Задать вопрос

Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

+5
Ответы (1)
  1. 26 февраля, 01:59
    0
    program two_digits;

    var m, m1, n: integer;

    //m и m1 - цифры, стоящие в числе рядом.

    //Определяются как остатки от деления числа n на 10,

    //которое в цикле два раза делиться нацело на 10, и таким

    //образом шаг за шагом теряет свои младшие разряды

    begin

    writeln ('Введите число');

    readln (n);

    s: = 'No';

    m1: = - 1;

    while n > 0 do

    begin

    m: = n mod 10;

    if m = m1 then s: = 'Yes';

    n: = n div 10;

    m1: = n mod 10;

    if m = m1 then s: = 'Yes';

    n: = n div 10

    end;

    writeln (s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая определяет, верно ли, что введённое число - - трёхзначное. Входные данные: Входная строка содержит единственное натуральное число.
Ответы (1)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Программа в Паскаль Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения. Входные данные Входная строка содержит единственное вещественное число в диапазоне от 0 до 8.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу, которая заполняет массив первыми N натуральными числами и выводит его. Входные данные Входная строка содержит размер массива N. Гарантируется, что 0 < N ≤ 10000.
Ответы (1)