Задать вопрос
23 марта, 10:25

Дано натуральное число n. написать программу выводящую первых n нечётных чисел 1,3,5

+2
Ответы (1)
  1. 23 марта, 13:19
    0
    Программа на языке программирования PascalABC выглядит так:

    program z1;

    uses crt;

    var n, i:integer;

    begin

    writeln ('введите число n');

    read (n);

    for i:=1 to n do

    if i mod 20 then write (i,' ');

    end.

    Это первый способ решения задачи с использованием оператора цикла for.

    Второй способ решения с использованием оператора цикла while имеет вид:

    program z2;

    uses crt;

    var n, i:integer;

    begin

    writeln ('введите число n');

    read (n);

    i:=1;

    while i<=n do

    if i mod 20 then begin write (i,' ');

    i:=i+2;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число n. написать программу выводящую первых n нечётных чисел 1,3,5 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
1) Написать программу вывода всех четных чисел от 2 до 1000 включительно2) Написать программу определяющую сумму всех нечетных чисел от 1 до 99
Ответы (1)
3) Дан массив из 15 целых чисел (вводятся случайным образом в диапазоне от 1 до 100). Составить программу, вычисляющую и выводящую на экран сумму шести первых элементов.
Ответы (1)
Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел.
Ответы (1)