Задать вопрос
30 декабря, 08:21

Сформулировать массив из n случайных чисел на промежутке [-60; 60]. найти сумму чисел больших нуля

+1
Ответы (1)
  1. 30 декабря, 12:10
    0
    var

    i, sum1, n : integer; / / объявляем переменные целочисленного типа.

    arr : array of integer; / / объявляем массив.

    Begin

    writeln ('Введите размерность массива:'); / / вывод строки на экран.

    read (n); / / считываем размерность массива.

    setlength (arr, n); / / выделяем память под массив.

    for i: = 0 to (n-1) do / / начало цикла.

    begin

    arr[i] : = random (-60, 60); / / заполняем элемент массива числом из диапазона - 60; 60.

    if (arr[i] > 0) then sum1 : = sum1 + arr[i]; / / считаем сумму положительных элементов.

    end;

    writeln ('Сумма положительных чисел массива равна:', sum1); / / вывод строки на экран.

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Сформулировать массив из n случайных чисел на промежутке [-60; 60]. найти сумму чисел больших нуля ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)