Задать вопрос
19 февраля, 01:31

Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне. Напишите программу, подсчитывающую общую сумму всех денег, подаренных к - му дню рождения. Формат входных данных На вход программе подается единственное число. Это в паскале

+3
Ответы (1)
  1. 19 февраля, 04:14
    0
    Begin

    writeln ('Введите возраст в годах');

    readln (k);

    s : = 1;

    total : = 1;

    if k = 1 then total : = 1 else

    begin

    For i:integer : = 2 to k do

    begin

    s : = 2 * s + 1;

    total : = total + s;

    end

    end;

    Writeln ('Общая сумма подаренных долларов составила ', total)

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
2. Составить программу к следующей задаче: "Американский дедушка, подарил своему внуку на 1 день рождения 1$. Каждый следующий день рождения он удваивал свой предыдущий подарок и прибавлял к нему сколько долларов, сколько лет исполнялось внуку.
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)
Напишите программу на любом вам известном алгоритмическом языке. На вход программе подаётся число N. Программа формирует N случайных чисел сумму тех из них остаток от деления которых на 5 больше двух
Ответы (1)
Дается последовательность из N чисел. Найдите количество различных чисел. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000).
Ответы (1)