Задать вопрос

Найти сумму целочисленного массива В, состоящего из 15 элементов

+2
Ответы (1)
  1. 9 марта, 14:18
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    b:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    b[i]:=random (2001) - 1000;

    for i:=1 to n do / / выводим полученный массив на экран

    write (b[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    s:=s + b[i]; / / получаем сумму элементов массива

    writeln (' сумма элементов = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму целочисленного массива В, состоящего из 15 элементов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
запишите программу, в которой осуществляется: заполнение случайным образом целочисленного массива а, состоящего из 10 элементов, значения которых изменяются в диапазоне от 0 до 99; вывод массива а на экран
Ответы (1)
74. Известны значения элементов одномерного целочисленного массива a, состоящего из 5 элементов. Чему равно значение а[а[1]]?
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)