Задать вопрос
30 декабря, 20:40

1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14; a: = (а div 100) * 100; 3) Составить алгоритм, в котором меньшее из двух данных чисел заменяется суммой этих чисел.

+5
Ответы (1)
  1. 30 декабря, 23:27
    0
    1)

    a: = 86

    b: = a mod 10 + 14 = 86 mod 10 + 14 = 6 + 14 = 20

    a: = а div 3 * 5 = 86 div 3 * 5 = 28 * 5 = 140

    Ответ: значение переменной a = 140, значение переменной b = 20

    2)

    a: = 8673

    b: = (a mod 100) * 10 + 14 = (8673 mod 100) * 10 + 14 = 73 * 10 + 14 = 730 + 14 = 744

    a: = (а div 100) * 100 = (8673 div 100) * 100 = 86 * 100 = 8600

    Ответ: значение переменной a = 8600, значение переменной b = 744

    3)

    var a, b:integer;

    begin

    write (' введите число а ');

    read (a);

    write (' введите число b ');

    read (b);

    if a < b then a:=a + b else b:=b + a;

    write (a,' ', b);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Чему будет равно значение переменной с в результате выполнения фрагмента программы а:=125; b:=25; с:=12; if a div 25=0 then if a mod 12=0 then ... c:=b div (a mod c) else c:=a div (b mod c) 1) 0; 2) 1; 3) 12; 4) 125.
Ответы (1)