Задать вопрос

Pascal ABC. Для двумерного массива 9*9 найдите элемент, который расположен "по центру" (т. е. от него до левого края и до правого края, до верхнего края и до нижнего края одинаковое расстояние). Какая у него координата?

+2
Ответы (1)
  1. 22 июня, 03:08
    0
    Var i, j, x, y: integer;

    a: array [1 ... 9,1 ... 9] of integer;

    begin

    //заполнение массива данными

    for i:=1 to 9 do

    for j:=1 to 9 do

    begin

    a[i, j]: = random (100);

    end;

    //вывод массива

    for i:=1 to 9 do

    begin

    for j:=1 to 9 do

    begin

    write (a[i, j], ' ');

    end;

    writeln ();

    end;

    //определение координаты x

    x:=round (9/2) + 1;

    //определение координаты y

    y:=round (9/2) + 1;

    //вывод значения массива, расположенного по координатам x и y

    writeln (a[x, y], ' - центр двумерного массива c координатами x = ', x, ', y = ', y);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Pascal ABC. Для двумерного массива 9*9 найдите элемент, который расположен "по центру" (т. е. от него до левого края и до правого края, до ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1) Написать программу, которая определяет номера строк двумерного массива A[1 ... 6,1 ... 4], в которых содержится хотя бы один нулевой элемент. 2) 5. Составить программу заполнения массива B[1 ...
Ответы (1)
Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).
Ответы (1)