Задать вопрос

Дан массив 50 чисел. От 0 до 50. Нужно написать программу, чтобы пользователь вводил 5 любых цифр от 0 до 50 и программа находила самое минимальное число из пяти. Также провести операция с 26 любыми цифрами. Язык - Паскаль.

+2
Ответы (1)
  1. 6 января, 10:02
    0
    var a:array[0 ... 50] of integer;

    for b:array[1 ... 5] of integer;

    c:array[1 ... 26] of integer;

    i, bmin, cmin:integer;

    begin

    for i:=0 to 50 do a[i]:=i;

    writeln ('Введите 5 чисел');

    for i:=1 to 5 do readln (b[i]);

    if (b[1]=0) then (if b[2]=0) then

    if (b[3]=0) then if (b[4]=0) then

    if (b[5]=0) then begin

    bmin : = b [ 1 ];

    for i : = 2 to 5 do begin

    if bmin > a [ i ] then bmin : = a [ i ];

    e nd;

    writeln ('Введите 26 чисел');

    for i:=1 to 26 do readln c[i];

    cmin : = c [ 1 ];

    for i : = 2 to 5 do begin

    if cmin > a [ i ] then cmin : = a [ i ];

    e nd;

    writeln (bmin, cmin);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив 50 чисел. От 0 до 50. Нужно написать программу, чтобы пользователь вводил 5 любых цифр от 0 до 50 и программа находила самое ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n чисел.
Ответы (1)
Составьте паскаль-программу для решения следующей задачи: "Дан одномерный массив действительного типа. Получить другой массив, состоящий только из чисел исходного массива, больших данного числа N, или сообщить, что таких чисел нет.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)