Задать вопрос
5 мая, 11:15

ввести a, b и c и вычислить x = (a*b-c) / (2+a), если a+b>0 или a<0, x=a-b в противном случае написать программу pascal

+1
Ответы (1)
  1. 5 мая, 11:48
    0
    program zz1;

    var a, b, c:integer; / /задаем переменные целого типа

    x:real; //задаем переменную не целого типа

    begin

    write (' введите первое число a '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число b '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число c '); / / вводим с клавиатуры третье число

    read (c);

    if (a + b > 0) then x: = (a * b - c) / (2 + a); //в зависимости от условия вычисляем ответ

    if (a < 0) then x: = (a - b);

    write (' полученный результат = ', x:5:2); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «ввести a, b и c и вычислить x = (a*b-c) / (2+a), если a+b>0 или a ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике