Задать вопрос

Напишите программу на языке Паскаля для задачи: Ввести возраст человека (от 1 до 150) и ввести его вместе с последующими словами "год" года" "лет". Пример: Введите возраст: 24 Вам 24 года.

+3
Ответы (1)
  1. 21 января, 18:24
    0
    Для выбора варианта из набора "год", "года", "лет" используется оператор case.

    program age;

    var n, k: integer;

    s: string;

    begin

    write ('Введите возраст: ');

    readln (n);

    k: = n mod 10;

    case k of

    1: s:='год';

    2,3,4: s:='года';

    5,6,7,8,9,0: s:='лет'

    end;

    writeln ('Вам ', n,' ', s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу на языке Паскаля для задачи: Ввести возраст человека (от 1 до 150) и ввести его вместе с последующими словами "год" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)
Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с последующим словом "год","года" или "лет".
Ответы (1)