Задать вопрос
2 декабря, 17:06

Дан массив 5 на 5. Найдите максимальное значение для каждого столбца и индексы максимального значения всего массива. Найдите сумму главной диагонали. 36 26 5 19 62 46 83 99 26 50 63 51 86 62 63 10 24 59 26 73 8 14 13 15 15

+4
Ответы (1)
  1. 2 декабря, 18:01
    0
    program zz1;

    const n = 5;

    m = 5; / / задаем количество элементов в массиве

    b:array [1 ... n, 1 ... m] of integer = ((36, 26, 5, 19, 62), (46, 83, 99, 26, 50), (63, 51,

    86, 62, 63), (10, 24, 59, 26, 73), (8, 14, 13, 15, 15));

    var i, j, max1, max2, s:integer; / / задаем переменные целого типа

    begin

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to m do

    write (b[i, j]:4);

    writeln;

    end;

    for j:=1 to n do

    begin

    for i:=1 to m do

    begin

    if b[i, j]>max1 then max1:=b[i, j]; / / находим максимальный для каждого столбца

    if b[i, j]>max2 then max2:=b[i, j]; / / находим максимальный для всего массива

    if i=j then s:=s + b[i, j]; / / находим сумму на главной диагонали

    end;

    writeln (' в ', j,'-ом столбце максимальный элемент = ', max1); / /выводим ответ

    max1:=0;

    end;

    writeln ('максимальный элемент во всем массиве = ', max2); / /выводим ответ

    writeln ('сумма элементов на главной диагонали = ', s); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив 5 на 5. Найдите максимальное значение для каждого столбца и индексы максимального значения всего массива. Найдите сумму главной ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
1. Дан двумерный массив. Найти сумму элементов этого массива. 2. В одномерном массиве сосчитать количество элементов равных 0 3. Дан двумерный массив. Найти произведение элементов каждого столбца.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)