Задать вопрос

Вычислить сумму всех элементов матрицы X размером 8*8

+5
Ответы (1)
  1. 28 июля, 03:27
    0
    Для решения данной задачи используется структура с вложенным (двойным) циклом.

    Первый двойной цикл формирует исходный массив путем запроса его значений у пользователя (ввод осуществляется с клавиатуры), второй двойной цикл осуществляет построчное сложение элементов введенного ранее массива.

    Program Zadachka;

    Var i, j:ineger; S:real;

    a:array [1 ... 8,1 ... 8] of real;

    begin

    for i:=1 to 8 do

    for J:=1 to 8 do read (a[i, j]);

    s:=0;

    for i:=1 to 8 do

    for J:=1 to 8 do S:=s+a[i, j];

    Writeln (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму всех элементов матрицы X размером 8*8 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Дана квадратная матрица а размером n*n состоящая из действительных элементов. Найти среднее арифметическое из всех отрицательных элементов этой матрицы
Ответы (1)