Задать вопрос

Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc

+5
Ответы (1)
  1. 28 января, 01:47
    0
    var a:array[1 ... 3,1 ... 3] of integer;

    b:array[1 ... 3,1 ... 3] of integer;

    c:array[1 ... 3,1 ... 3] of integer;

    i, j:integer;

    begin;

    writeln ('A array:');

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    a[i, j]:=random (10) - 10;

    write (a[i, j]:4);

    end;

    end;

    writeln;

    writeln ('B array:');

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    b[i, j]:=random (-10,10);

    write (b[i, j]:4);

    end;

    end;

    writeln;

    writeln ('C array:');

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    c[i, j]:=a[i, j]*b[i, j];

    write (c[i, j]:4);

    end;

    end;

    end.

    Второй вариант выполнения программы:

    var a:array[1 ... 1000,1 ... 1000] of integer;

    i, j, k, n, u:integer;

    begin;

    randomize;

    readln (n);

    writeln ('A array:');

    for i:=1 to n do begin;

    writeln;

    for j:=1 to n do

    begin;

    a[i, j]:=random (10) - 10;

    write (a[i, j]:4);

    end;

    end;

    for i:=1 to n do begin;

    for j:=1 to n do

    u+=a[i, j];

    if u<0 then inc (k);

    u:=0;

    end;

    writeln;

    write ('Result:', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
1. Составьте программу вывода матрицы: 1 1 1 1 2 2 2 2 3 3 3 3 2. Составьте программу вывода матрицы: 1 2 3 4 1 2 3 4 1 2 3 4
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)