Задать вопрос

Найти номера минимального и максимального элементов массива, в Паскале

+3
Ответы (1)
  1. 27 апреля, 06:38
    0
    program zz1;

    const n = 14; / /задаем количество элементов в массиве

    var i, max1, min, k, k1:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (201) - 60;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0;

    for i:=1 to n do / / находим максимальный элемент

    if m[i]>max1 then begin max1:=m[i]; k:=i; end;

    writeln (' номер максимального элемента = ', k); / / выводим ответ

    min:=1000000; / /задаем начальное значение для минимального элемента

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    if m[i] < min then begin min:=m[i]; k1:=i; end; / /проверяем, если число из массива меньше минимального, то записываем его в минимальное

    write (' номер минимального элемента = ', k1); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти номера минимального и максимального элементов массива, в Паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)