Задать вопрос
21 августа, 23:04

Найти площадь прямоугольника по стороне и диагонали. В паскале

+4
Ответы (1)
  1. 22 августа, 02:55
    0
    program zz1;

    var a, b, n, s:real; / / задаем переменные не целого типа

    begin

    write (' введите известную сторону прямоугольника '); / / вводим с клавиатуры число

    read (a);

    write (' введите диагональ прямоугольника '); / / вводим с клавиатуры число

    read (n);

    b:=sqrt (n*n - a*a); / / вычисляем вторую сторону прямоугольника по теореме Пифагора

    s:=a * b; / / вычисляем площадь прямоугольника по формуле

    write (' площадь прямоугольника = ', s:5:2); / / выводим ответ в формате пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти площадь прямоугольника по стороне и диагонали. В паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
В классическом паскале нет функции возведения в степень. Если программисту на паскале все же потребуется возвести число a>0 в степень n, то с помощью какого выражения он может это сделать?
Ответы (1)
Написать программу (в Паскале), определяющую площадь четырехугольника по известным значениям четырех его сторон и одной диагонали.
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m'); readln (c, m); s:=c*m; writeln ('s=', s); readln; end.
Ответы (1)
Вычислить площадь прямоугольника по известным стороне и диагонали. Нужно написать алгоритм на языке Паскаль.
Ответы (1)