Задать вопрос

В массиве записаны оценки по информатике 22 учеников класса. Определить кол-во учеников, оценка которых меньше средней оценки по классу, и вывести номера элементов массива, соответствующих этим ученика.

+3
Ответы (1)
  1. 23 ноября, 03:24
    0
    Решение. Введем следующие обозначения: а - массив из 22 элементов (формировать его будем случайными целыми числами из промежутка [1; 5]); i - порядковый номер элементов массива; a[i] - значения элементов массива (отметки учащихся); sr - средняя отметка по классу; n - количество учащихся, у которых отметка ниже средней по классу. Будем использовать оператор цикла с параметром for. Тогда программа на языке программирования Pascal ABC может выглядеть так:

    program zadacha;

    uses crt;

    var i, n, s: integer;

    sr: real;

    a: array[1 ... 22] of integer;

    begin

    n:=0; s:=0;

    for i:=1 to 22 do begin

    a[i]:=random (5-1+1) + 1;

    write (a[i], ' ');

    s:=s+a[i];

    end;

    writeln;

    sr:=s/22; writeln ('sr=', sr:2:2);

    for i:=1 to 22 do

    if a[i]
    n:=n+1;

    write ('i=', i, ' ');

    end;

    writeln;

    write ('n=', n);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве записаны оценки по информатике 22 учеников класса. Определить кол-во учеников, оценка которых меньше средней оценки по классу, и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Дан массив состоящий из n элементов. вывести максимальный элемент массива и его индекс. Если в массиве содержится несколько максимальных элементов, посчитать количество максимальных элементов, вывести максимальное значение и индексы элементов его
Ответы (1)