Задать вопрос
4 февраля, 09:38

Сформировать одномерный массив из N элементов (значения элементов задаются случайным образом в диапазоне от - 20 до 80). Вывести массива на экран. Найти среднее арифметическое чётных элементов массива, количество элементов с нечётными индексами и сумму элементов, больших 30. (Составить программу)

+2
Ответы (1)
  1. 4 февраля, 11:23
    0
    program zz1;

    const n = 50; / / задаем количество элементов в массиве

    var i, s, k, s1, p:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (101) - 20;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    begin

    if m[i] mod 2 = 0 then begin s:=s + m[i]; k:=k + 1; end;

    if i mod 2 = 1 then p:=p + 1;

    if m[i] > 30 then s1:=s1 + m[i];

    end;

    writeln (' среднее арифметическое четных = ', s/k); / / выводим ответ

    writeln (' количество элементов с нечетными индексами = ', p);

    writeln (' сумма элементов больших 30 = ', s1);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Сформировать одномерный массив из N элементов (значения элементов задаются случайным образом в диапазоне от - 20 до 80). Вывести массива на ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)