Задать вопрос

Напишите программу вычисления выражения: s=1!+2!+3! + ... + n! Здесь n! - факториал числа n. n!=1*2 * ... * (n-1) * n. Используйте функцию вычисления факториала.

+1
Ответы (1)
  1. 5 декабря, 21:52
    0
    function fak (n: integer) : uint64;

    var

    i: integer;

    rez: uint64;

    begin

    rez : = 1;

    for i : = 1 to n do

    rez : = rez * i;

    fak : = rez;

    end;

    var

    s, i, n: integer;

    begin

    readln (n);

    for i : = 1 to n do

    s : = s + fak (i);

    write (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу вычисления выражения: s=1!+2!+3! + ... + n! Здесь n! - факториал числа n. n!=1*2 * ... * (n-1) * n. Используйте функцию ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Дан двумерный массив размером n*n. Создать функцию которая находит факториал каждого элемента массива и заменяет исходный элемент на его факториал (значение функции). в первой строке написано число n.
Ответы (1)
Составить блок схему и программу для вычисления факториала числа P=n!1*2*3 ... * n
Ответы (1)
Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
Ответы (1)
Напишите программу для вычисления наибольшего общего делителя двух целых чисел: а) используйте оператор repeat б) используйте оператор while
Ответы (1)