Задать вопрос
23 декабря, 11:02

Напишите программу, которая заполняет массив случайными целыми числами, вводит с клавиатуры целое число N и копирует в новый массив все числа из исходного массива, для которых сумма значений всех цифр равна N.

+2
Ответы (1)
  1. 23 декабря, 14:55
    0
    const nmax=100;

    function summa (a:integer) : integer;

    var b, s:integer;

    begin

    b:=abs (a);

    s:=0;

    while b>0 do

    begin

    s:=s+b mod 10;

    b:=b div 10;

    end;

    result:=s;

    end;

    var a:array[1 ... nmax] of integer;

    m, n, i, k:integer;

    begin

    randomize;

    repeat

    write ('Введите размер массива от 2 до ', nmax,' m=');

    readln (m);

    until m in [2 ... nmax];

    writeln ('Массив');

    for i:=1 to m do

    begin

    a[i]:=-99+random (1099);

    write (a[i]:4);

    end;

    writeln;

    repeat

    write ('Введите искомую сумму цифр n>0 n=');

    readln (n);

    until n>0;

    k:=0;

    for i:=1 to m do

    if summa (a[i]) = n then

    begin

    write (a[i]:4);

    k:=1;

    end;

    if k=0 then write ('Нет чисел с такой суммой цифр');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая заполняет массив случайными целыми числами, вводит с клавиатуры целое число N и копирует в новый массив все ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Составьте программу которая заполняет массив а 1.10 случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексами от n до m включительно. Числа n и m введите с клавиатуры
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)