Задать вопрос
8 марта, 04:12

Составить программу для решения следующей задачи: Дан массив А целых чисел в интервале [-10 ... 10]. Подсчитать в нем количество элементов, равных 5

+4
Ответы (1)
  1. 8 марта, 05:38
    0
    Решение на Turbo Pascal.

    uses crt;

    var mas: array [1 ... 15] of integer;

    i, k: byte;

    begin

    clrscr;

    randomize;

    for i:=1 to 15 do

    begin

    mas[i]:=random (5);

    write (mas[i],' ');

    end;

    writlen ('New massiv');

    for i:=1 to 15 do

    begin

    if mas[i]=5 then k:=k+1 else mas[i]:=1;

    write (mas[i],' ');

    end;

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу для решения следующей задачи: Дан массив А целых чисел в интервале [-10 ... 10]. Подсчитать в нем количество элементов, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)