Задать вопрос

С клавиатуры вводится число N, а за ним N элементов массива состоящего из целых чисел. Проверить, все ли элементы массива положительны. Если да, то ввести фразу "ДА", в противном случае-"Нет".

+3
Ответы (1)
  1. 14 октября, 06:57
    0
    Первый вариант выполнения программы:

    const

    C = 100;

    var n, i : Integer;

    a : array [1 ... C] of Integer;

    flag : Boolean;

    begin

    Write ('N: ');

    Readln (n);

    if (n C) then

    begin

    Write ('Ошибка, недопустимое число.');

    Exit;

    end;

    for i : = 1 to n do

    begin

    Write ('a[', i,']: = ');

    Readln (a[i]);

    end;

    flag : = False;

    for i : = 1 to n do

    if a[i] < 1 then

    begin

    flag : = True;

    Break;

    end;

    if flag then Writeln ('НЕТ') else Writeln ('ДА');

    Readln;

    end.

    Второй:

    program massivn;

    uses crt;

    type massiv=array[0 ... 50] of integer;

    var a:massiv;

    n, i, k:integer;

    begin

    writeln ('vvedite n');

    readln (n);

    for i:=1 to n do begin

    a[i]:=random (100) - 10;

    write (a[i]:3);

    end;

    for i:=1 to n do

    if a[i]>0 then k:=k+1;

    writeln;

    if k=n then writeln ('DA') else writeln ('NET');

    end
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводится число N, а за ним N элементов массива состоящего из целых чисел. Проверить, все ли элементы массива положительны. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Найдите наибольший элемент одномерного массива, состоящего из 12 элементов. Элементы задаются датчиком случайных чисел из интервала [-25,31] 2. Массив А вводится с клавиатуры.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)