Задать вопрос

Дан целочисленный массив из 40 элементов, которые могут принимать значения от 150 до 190 - рост учащихся выпускного класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Напишите программу, которая подсчитывает число претендентов в состав баскетбольной команды и выводит номера подходящих кандидатур.

+4
Ответы (1)
  1. 4 сентября, 16:04
    0
    var

    i, x : integer; / / объявляем переменные целочисленного типа.

    arr : array [1 ... 40] of integer; / / объявляем массив.

    Begin

    for i: = 1 to 40 do / / начало цикла.

    begin

    arr[i] : = random (150,190); / / заполняем элемент массива с индексом i случайным числом.

    if arr[i] > = 180 then / / если рост от 180 см.

    begin

    writeln ('Номер кандидатуры: ', i, ' его рост: ', arr[i], ' см.'); / / вывод строки на экран.

    x: = x + 1; / / считаем количество претендентов.

    end;

    end;

    writeln ('Общее количество претендентов в команду: ', x); / / вывод строки на экран.

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан целочисленный массив из 40 элементов, которые могут принимать значения от 150 до 190 - рост учащихся выпускного класса. В баскетбольную ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 - рост учащихся выпускного класса. Напишите программу, которая выводит номера элементов с максимальными и минимальными значениями. 2.
Ответы (1)
Запишите на языке Паскаль программу решения задачи номер 34 к § 3.4. Считайте рост претендента в команду случайным числом из диапозона от 150 до 200 см, а число претендентов n=50. (Номер задачи 34 - Объявлен набор в школьную баскетбольную команду.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от - 20 до 20. Написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)