Задать вопрос
29 ноября, 03:14

Массив (n, n), найти кол-во положительных чисел и сумму отриц. [-10; 10]

+2
Ответы (1)
  1. 29 ноября, 05:11
    0
    var

    i, x, sum, n : integer; / / объявляем переменные целочисленного типа.

    arr : array of integer; / / объявляем массив.

    Begin

    writeln ('Введите размерность массива:'); / / вывод строки на экран.

    read (n); / / считываем размерность массива.

    setlength (arr, n); / / выделяем память под массив.

    for i: = 0 to (n-1) do / / начало цикла.

    begin

    arr[i] : = random (-10, 10); / / заполняем элемент массива числом из диапазона - 10; 10.

    if (arr[i] > 0) then x: = x + 1; / / считаем количество положительных элементов.

    if (arr[i] < 0) then sum : = sum + arr[i]; / / считаем сумму отрицательных элементов.

    end;

    writeln ('Количество положительных элементов в массиве: ', x); / / вывод строки на экран.

    writeln ('Сумма отрицательных элементов массива равна: ', sum); / / вывод строки на экран.

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Массив (n, n), найти кол-во положительных чисел и сумму отриц. [-10; 10] ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Массив (n, n), найти кол-во положительных чисел и сумму отриц. [-10; 10] написать программу в ABC
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)