Задать вопрос

Дан файл из чисел. Создать второй файл из чисел первого файла, у которых сумма цифр находится в пределе от 12 до 34. Pascal

+2
Ответы (1)
  1. 24 апреля, 23:08
    0
    Assign (F, 'Result. txt');

    Rewirte (F);

    Readln (N);

    S : = 0;

    for i:=1 to N do begin

    B : = Sqr (i - 1);

    WriteLn (F, B);

    if not Odd (B) then S : = S + B;

    end;

    Close (F);

    WriteLn ('Сумма четных чисел = ', S);

    Описание переменных и остальное оформление самостоятельно.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан файл из чисел. Создать второй файл из чисел первого файла, у которых сумма цифр находится в пределе от 12 до 34. Pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
У нас есть. bat файл. Если прописать: echo [Команда]>[Место сохранения]/Имя файла echo [Команда]>[Место сохранения]/Имя файла Имя файла одинаковое в двух случаях, но при запуске этого файла, создается бат файл и эти две (Или больше) команды
Ответы (1)
1. Файл размером 4 Мбайт передаётся через некоторое соединение за 100 секунд. Определите размер файла (в Кбайтах), который можно передать через это же соединение за 75 секунд. 2.
Ответы (1)
Установите соответствие между типами файлов и расширениями файлов. Текстовый файл Графический файл Web-страница Звуковой файл Видеофайл Системный файл Исполняемый файл txt bmp htm doc jpg mp3 html gif midi mpeg sys exe avi com
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Выберите (отметьте галочкой) действия, которые могут быть выполнены в текстовом процессоре в режиме работы с файлами: Открытие файла Редактирование файла Форматирование файла Поиск и замена текста Проверка правописания Изменение параметров страницы
Ответы (1)