Задать вопрос

Составьте программу которая формирует массив из 20 случайных чисел от - 10 до 10 и находит отрицательные элементы

+1
Ответы (1)
  1. 30 июля, 18:32
    0
    program zz1;

    const n = 20; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21) - 10;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if m[i] < 0 then write (' ', m[i]); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая формирует массив из 20 случайных чисел от - 10 до 10 и находит отрицательные элементы ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Составьте программу, которая формирует массив из 12 случайных целых чисел на промежутке от - 40 до 10 и находят элементы, больше - 10 и меньше 5
Ответы (1)
Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 элементов массива
Ответы (1)
Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из которых находится в диапазоне от - 15 до 15, и выводит на экран вначале исходные, а затем только отрицацельные элементы массива
Ответы (1)