Задать вопрос
8 сентября, 07:32

Найти минимальный элемент в целочисленном массиве А. размерностью 15 элементов

+1
Ответы (1)
  1. 8 сентября, 08:21
    0
    program zz1;

    const n = 15; / /задаем количество элементов в массиве

    var i, min:integer; / / задаем переменные целого типа

    a:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    a[i]:=random (21);

    for i:=1 to n do / /выводим массив на экран

    write (a[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    min:=100000;

    for i:=1 to n do / / находим минимальный элемент

    if a[i] < min then min:=a[i];

    writeln (' минимальный элемент = ', min); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти минимальный элемент в целочисленном массиве А. размерностью 15 элементов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
Дан массив из 10 элементов - случайных чисел из диапазона [-30; 30].1, Подсчитать в нем кол-во элементов, равных заданному числу. 2, Найти минимальный и максимальный элемент в массиве и их номера. 3, Отыскать в массиве локальные минимумы и максимумы.
Ответы (1)
1) Вычислите сумму элементов одномерного массива А (10). 2) Вычислите произведение элементов одномерного массива А (10). 3) Вычислите сумму четных чисел в массиве А (10). 4) Задан массив из N элементов. Определить максимальный (минимальный) элемент.
Ответы (1)
1) Найти минимальный чётный элемент в массиве и его индекс. 2) Заполнить одномерный массив степенями числа 2. Всего 10 элементов в массиве.
Ответы (1)