Задать вопрос

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.

+2
Ответы (1)
  1. 29 мая, 16:21
    0
    Program min_mas;

    var {объявляем переменные которые будем использовать в программе}

    i, min, max:integer;

    a:array[1 ... 50] of integer;

    begin

    randomize; {используя генератор случайных чисел заполняем и выводим на экран массив}

    for i:=1 to 50 do

    begin

    a[i]:=random (100);

    write (a[i],' ');

    end;

    min:=a[1]; {Присваиваем минимальному значению значение первого элемента массива }

    for i:=1 to 50 do

    begin {проверяем каждый элемент массива является ли он нечетным и сравниваем его с первым элементом}

    if (a[i] mod 2 0) and (a[i]
    end;

    writeln;

    writeln ('Min=', min);

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
нужно составить программу для нахождения минимального элемента и его индекса в целочисленном массиве a из 10 элементов заполненных числами из интервала - 48; 86
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Написать программу, которая в одномерном массиве, заданном вводом с клавиатуры вычисляет среднее арифметическое массива без максимального и минимального элемента массива.
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 300. Опишите на русском языкке или на паскале алгоритм, который позволит найти произведение тех элементов массива, которые имеют нечётный индекс и кратны трем.
Ответы (1)