Задать вопрос
26 мая, 19:55

Дана строка, содержащая слова. Некоторые из слов взяты в скобки. Написать программу, выводящую исходную строку без скобок.

+4
Ответы (1)
  1. 26 мая, 20:02
    0
    program zz1;

    var s, s1:string;

    i, d:integer;

    begin

    read (s); / /вводим исходную строку

    d:=length (s); / /определяем длину исходной строки

    for i:=1 to d do / /перебираем в цикле все буквы от первой до последней

    if (s[i]' (') and (s[i]') ') then s1:=s1+s[i]; / /проверяем, если буква из строки неравна скобке " (" и неравна скобке ") ", то пишем эту букву в конец другой строки

    writeln (s1); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана строка, содержащая слова. Некоторые из слов взяты в скобки. Написать программу, выводящую исходную строку без скобок. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку, добавляя после каждого символа символ '0'.
Ответы (1)
Дана строка, содержащая путь к имени файла, например C:/webserver/home/test/file. doc. Выделите из этой строки имя файла без расширения.
Ответы (1)
В начальный момент времени записана цифра 0. На каждом из следующих девяти шагов выполняются такие действия: в очередную строку записывается следующая по порядку цифра, после чего записывается предыдущая строка в обратном порядке.
Ответы (1)
Дана строка, содержащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие три буквы.
Ответы (1)