Задать вопрос
7 ноября, 01:57

Y=tgx при х изменяется от 0 до 10 Написать программу так чтобы она решала задачу с использованием оператора цикла

+2
Ответы (1)
  1. 7 ноября, 05:33
    0
    Первый вариант выполнения задачи:

    const

    a = 0;

    b = 10;

    var

    x, y, h: real;

    begin

    h : = 0.5;

    x : = a;

    repeat

    y : = sin (x) / cos (x);

    writeln ('x = ', x:4:1, ' y = ', y:6:3);

    x : = x + h;

    until x > b;

    end.

    Второй вариант выполнения задачи:

    function tg (a:real) : real;

    begin

    tg:=sin (a) / cos (a);

    end;

    var

    y:real; x:integer;

    begin

    for x:=0 to 10 do begin

    y:=tg (x);

    writeln ('Y=', y);

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Y=tgx при х изменяется от 0 до 10 Написать программу так чтобы она решала задачу с использованием оператора цикла ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вывести все числа от 1 до 1000, которые: - - кратны и 3 и 5 и сделай чтобы цикл начинался с 1000, а заканчивался на 1 т. е. чтобы в первой итерации цикла i было равно 1000 а в последней - 1 итерация цикла - один прогон цикла
Ответы (1)
Чему равно количество повторений тела оператора цикла с параметром, если параметр цикла принимает все целые значения от a до b
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Проанализируйте работу программы. program math; var х, у: integer; begin x: = 1; у:=1; while x=5? 6) Сколько раз исполнится тело цикла, если изменить условие на х>0? 7) Что произойдёт, если из тела цикла убрать команду х: = х+1?
Ответы (1)
напишите программу для вычисления n-ной степени числа х. вычисления описать вкаждым из трех вариантов оператора цикла
Ответы (1)