Задать вопрос
27 декабря, 06:33

Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы. Выходные данные Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки (ровно 3 знака с учетом округления). Примеры входные данные 4 5 7 выходные данные 4+5+7=16 4*5*7=140 (4+5+7) / 3=5.333

+3
Ответы (1)
  1. 27 декабря, 07:31
    0
    Программа рассчитана на введение чисел до 1000.

    program calc;

    var a, b, c: integer;

    begin

    writeln ('Введите три целых числа через пробел');

    readln (a, b, c);

    writeln (a,' + ', b,' + ', c, ' = ', a + b + c);

    writeln (a,' * ', b,' * ', c, ' = ', a*b*c);

    writeln (' (', a,' + ', b,' + ', c, ') / 3 = ', (a + b + c) / 3 : 8 : 3)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки.
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)