Задать вопрос

Дана строка. Найти сумму записанных в строке чисел.

+1
Ответы (1)
  1. 28 декабря, 03:27
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i, m, k:integer; / / задаем переменные целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    if (s[i] = '0') or (s[i] = '1') or (s[i] = '2') or (s[i] = '3') or (s[i] = '4') or (s[i] = '5') or / /проверяем, если символ строки цифра, то

    (s[i] = '6') or (s[i] = '7') or (s[i] = '8') or (s[i] = '9')

    then begin k:=strtoint (s[i]); m:=m + k; end; / / переводим символ в число и прибавляем его к сумме

    writeln (' сумма цифр в исходной строке = ', m); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана строка. Найти сумму записанных в строке чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных позициях считая слева направо, прибавили по 1. Получилась строка: "1322".
Ответы (1)
Дана строка. Найдите в этой строке второе вхождение буквы f, и выведите индекс этого вхождения. Если буква f в данной строке встречается только один раз, выведите число - 1, а если не встречается ни разу, выведите число - 2
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Дана строка содержащая текст записанный строчными русскими буквами. получить в другой строке тот же текст записанный заглавными бувами
Ответы (1)