Задать вопрос

Дан массив из N элементов. Написать программу, подсчитывающую произведение элементов массива

+5
Ответы (1)
  1. 31 марта, 13:27
    0
    Сначала в разделе описания var описываем одномерный массив А, который имеет размерность N.

    Элементы массива описываем как вещественные числа, можно описать и как целые, тогда вместо real нужно написать integer. С помощью оператора ввода read вводим значение N, далее считываем элементы массива. Переменная P - это произведение элементов массива. Сначала задаем ей значение один, так как произведение будет накапливаться. Далее организуем цикл с параметром for и выводим значение P на экран.

    var

    A: array[1 ... N] of real;

    n: integer;

    P: real;

    i: integer;

    begin

    write ('N=:');

    read (N);

    write ('Укажите значения элементов массива: ');

    for i : = 1 to N do

    read (A[i]);

    P: = 1;

    for i : = 1 to N do

    P: = P * A[i];

    Write ('Произведение элементов массива равно: ', P);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из N элементов. Написать программу, подсчитывающую произведение элементов массива ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Составить алгоритм и программу подсчитывающую количество меньших чем соседние элементов массива Z из 13 чисел. Значения элементов массива рассчитать по формуле WSinW, где W номер элемента массива
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)