Задать вопрос

Найдите сумму и количество элементов каждой строки больше среднего арифметического

+3
Ответы (1)
  1. 27 ноября, 02:30
    0
    program zz1;

    const n=3; / /задаем размер матрицы

    var matr:array[1 ... n, 1 ... n] of integer;

    i, j, s, kol:integer; sr:real;

    begin

    for i:=1 to n do / /заполняем матрицу случайными числами от - 10 до 10

    for j:=1 to n do

    matr[i, j]:=random (21) - 10;

    for i:=1 to n do / /выводим матрицу на экран

    begin

    for j:=1 to n do

    write (matr[i, j]:5);

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to n do

    s:=s+matr[i, j]; / /находим сумму элементов

    sr:=s / (n*n); / /находим среднее арифметическое

    writeln ('среднее арифметическое элементов матрицы = ', sr); / /выводим ответ

    for i:=1 to n do

    begin

    s:=0; kol:=0;

    for j:=1 to n do

    if matr[i, j]>sr then begin s:=s+matr[i, j]; kol:=kol+1; end; / /находим сумму и количество элементов

    writeln ('в ', i,'-ой строке сумма элементов больше среднего арифметического = ', s,' количество таких элементов = ', kol); //выводим ответ

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найдите сумму и количество элементов каждой строки больше среднего арифметического ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив В (n*m)). Элементы массива ввести случайным образом. Найти сумму элементов в каждой строке, больших среднего арифметического элементов данной строки Паскаль
Ответы (1)
Сформировать одномерный массив из 10 случайных элементов в диапазоне от 0 до 100. Найти количество элементов массива, больших среднего арифметического всех его элементов.
Ответы (1)
Дан массив из 12 элементов. Найти количество элементов, больше среднего арифметического всех ее элементов.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Напишите программу, которая вводит с клавиатуры 20 реальных чисел, и организовывает их хранение в массиве. После этого определяет сумму элементов, значение которых больше среднего арифметического элементов массива.
Ответы (1)